high temperature

  • 1
    Reply
  • 656
    views
  • Giovi03's Avatar
    Level 1
    Hi guys, i have a legion 5 gen 6 rtx 3070 ryzen 7, i see a lot of video on this laptop and it was very good but now that i have it i see that the temperature of gpu are higer comparared to the laptop of video, example, in warzone i have 80 degrees, in video of youtube 70, but in they video they have 120 fps with max resoluction, while i have 60 fps with minimum resolution and graphic, some one can help me?
  • 1 Reply

  • Liue's Avatar
    Level 17
    Hello @Glovi03!

    First of all, I would not be worried about 80C yet. Gaming PC's tend to use more power and push your device to limits in order to provide best possible gaming experience - that increases heat and makes your fans work harder. I would say as long as you stay under 85C-90C you should be fine. So many other things can affect it as well, like extremely hot summer we have experienced.

    But lets get into this issue:


    • I would like to ask you whatever you are using third-party software for your GPU, e.g. GeForce Experience? It is handy software to keep your GPU gaming drivers up-to-date, however it may also cause issues if used incorrectly. If yes, are you over-clocking? That is pretty easy to check: Press Alt + Z in order to open up GeForce Experience Overlay. Choose Performance tab and check target temperature and tuning method. Tuning method should have been set-up as Automatic in default. Target temperature should be set-up somewhere around 83C (which means that is still totally safe). Let me know how your settings are. Also remember to check out if you have over-clocking set on! If it is, disable it. Overclocking can be harmful for your PC and if being used, possible damage caused to GPU or for your device are not protected by warranty.
    • You were mentioning issues with FPS in Call of Duty: Warzone. Stucking into 60 FPS sounds like that you might have Vertical Sync (vsync) on in your in-game settings. You should check that out for sure. Get yourself into the game and open-up in-game settings. Proceed to Graphical Settings and look if Vertical Sync/Vsync has been turned "ON". If that is case, turn it "OFF" as Vertical Sync locks FPS to your monitor max refreshing rate (which almost in every case is 60). You should be able to increase your graphics to max now without having low FPS. If you got GeForce Experience, it also has an option to automatically optimize your games according to your PC capabilities. I use it all the time, so I do not have to deal with in-game graphic settings. Try it out.
    • ​​​​​​​And last, but definitely not least. Have you updated your GPU drivers? You should keep them up-to-date and not to download Windows Update ones. Those tend to be old-school and incapable of delivering good enough performance. Use NVIDIA's own drivers, either via GeForce Experience or manually from their website.


    Hope this helps. Hit me up here if you need more help.

    Cheers.
    Last edited by Liue; 13-07-22 at 14:43. Reason: Fixing how text looks.
    • Healer for Pro Finlandia on Silvermoon EU ‖ Priest, Shaman, Monk, Paladin ‖ Community Ambassador w/ Lenovo Legion ‖
    • Follow me on Twitter: Niato (@liueniato) / Twitter for all gaming related stuff!​​​​​​​

    ​​​​​​​​​​​​​​