Hi all,

I’m really struggling to understand/get RSR to work.

I set a game to a lower resolution, close the game, set the Go screen to a higher resolution and start the game but the Go then changes the screen resolution to match the game. It does this on every game I’ve tried.

However, if I connect to a 4k monitor it works fine, I open the AMD overlay and it says it’s upscaling to 4k even though windows has the monitor set to HD.

I don’t know if it’s something to do with the unit, or me!

Any help would be appreciated.

  • It may be a driver glitch, I've only tried using RSR on my desktop which is always set at the native panel resolution. It works as you have found with the 4K monitor plugged into the Go, so I would report this back to Lenovo if I were you and ask them to look into fixing it with one of the next driver or firmware updates for the device

  • I hope is a problem that could be solved by a driver update, I hope other users with a Legion Go will give some hints about this problem.

    Fortunately there are some staff members that may help you on the forum

  • RSR is disabled if you have AMD Fluid Motion Frames or HyperRX Profile on. Maybe this could be the problem.