Unsettling experience with GPU Drivers

I was working on trying to install the latest Chipset drivers (Legion Manager kept saying it wasn't updated).

So I manually installed them which for whatever reason broke the GPU driver. Having tried the AFM Drivers, it would be a piece of cake to just boot into safemode and DDU like previously.

NOPE. Ran the regular installwr again and Adrenaline was nowhere to be found. Did another DDU round, another MIA. Starting to panic at this point a little. Removed all the new chipset drivers, AGAIN ran DDU. Installed GPU driver, still no Adrenaline. Now I'm concerned. 

I extract the GPU driver instead of installing and try to run the Adrenaline installer. "No Compatible Device"...? Then I try as a hailmarry installing Adrenaline from the AFM drivers,  "No compatible Device"  

FFFF.......!

Here is what I ended up doing, mind that some steps oberlap with regular DDU procedures but in vluded anyway. Not sure it if will help anyone but it can't hurt to share. Keep in mind file paths may be a little different but the process is the same:

Turn off Wifi

Safe Mode via Windows Advanced Reset

Run DDU

Once Rebooted run GPU driver installer.

Extract instead of Install.

Open Device Manager, install below manually

C:\AMD\23.20.24.03\Packages\Drivers\Display\WT6A_INF\amduw23e.inf

Once installed, immediatly run

C:\AMD\23.20.24.03\Packages\Apps\UWP\radeonsoftware.msix_Windows10_PreinstallKit\6d4bb7489d374a978311125034a9efavc.msix

Reboot.

(This part may not be needed but did it anyway)

Rerun GPU driver installer, run in install mode.

Install Chipset Driver, preferably 5.09.16.731 (one on SD}

Reboot

  • Hey Mike, sorry about your troubled experience with the drivers! It is a little bit tedious and can be quite a headache if things don't work as intended. If you ever want to install the drivers manually from amd try using the YouTube videos below. I believe they are identical but they helped me out a lot. Hope this helps and happy gaming!

    https://www.youtube.com/watch?v=lT7NdZRMQe4

    https://www.youtube.com/watch?v=NeVdSlqLHMc

  • Nick,

    You mention trying the AFMF graphics driver. Did you have that driver installed prior to updating the chipset drivers?

    Where did you get the chipset driver from? AMD or Lenovo?

    Giving it a guess, perhaps the chipset driver you downloaded and tried to install was from Lenovo, while you had graphics drivers from AMD installed. This mismatch may resulted in problems.

    I’m glad you got it fixed though.

    I will reply with a picture of my Legion Space driver manager later. I ask that you let me know if it is similar to how yours look reporting the outdated chipset drivers. I have no reference point. Many people have mentioned this chipset being reported as outdated, but to date I do not recall a screen shot of how it looks in the software.

    Thanks Nick for all your contributions to the forum.

  • I got the amd drivers version 24.3.1 from AMD. These are the drivers that are officially released from amd with AFMF. They are not official for the Go yet and are still being worked on

  • The chipset driver you installed that you had a problem and conflict with the the official AMD graphics driver, was it from Lenovo or AMD?

  • They are from AMD but Space is just not displaying them correctly

  • Unfortunate, thanks for informing us Nick.

  • Yup that the same thing mine is displaying too