I really enjoy my Go but sometimes the stutters in games really annoy me. The avg FPS is good but the stutters are still there. Is there anyway to improve this aspect of a game? 


    I am going to make an assumption and say you have the game on the micro SD? If so, move it to the internal drive

  • Check the video below. Seems to be the drivers. In this video, he mentioned that Rog Ally had the same issues. I have also seen this issue quite a bit. I will have a game at 70+ FPS and get micro stutter for no reason no dips in FPS. Apex Legends runs amazing at 1080 and just gets a lot of this. Another game I noticed this one was Mass Effect Legendary Edition. Non-driver related make sure you are using enough power. A low TDP can cause stuttering as well. I have noticed decent frames for some games but because I have the watts too low it runs poorly. Like, For a few games were running at a decent frame rate with 8 watts but moving it to 9-12 stopped the stutter.

  • I’ve noticed that unless you lock the frame rate to 60 or 144 the games looks jittery and I don’t have this issue on my pc or steam deck. It’s rather annoying if a game runs below 60 fps and it just looks bad. 

  • If you watch the video the frame timing is all over the place which is a lot of what's causing it. If I see the issues my frame Rate never drops I just get the micro stutter. I did find it interesting that the video said that the Ally had the same issue that they fixed so it sounds like something with the Z1 that can be fixed. Hopefully, we get an update soon.

  • I do the same thing, lock my games at 60FPS. Hopefully the Legion GO2 will have VRR. 

  • Thank you so much for the link.

  • A number of games stutter if you have your GPU memory set to a specific amount in your bios such as Horizon Forbidden West, Hogworts Legacy. Setting it to auto usually sorts it as it forces pre shader compiling 

  • Hi  ,

    I heard this several times already, that Auto works better then a fixed memory amount in some games, but testing it so far I only had problems...

    When trying to use Auto and to switch the system resolution when being in game to 1600p to be able to use integer scaling the Legion Go simply crashes and there is no way around it with Dragon's Dogma 2.

    I found the 6 GB VRAM preset to be the most stable and reliable in most games. Haven't played Horizon Forbidden West, nor Hogwards Legacy though and still need to do a bit more of "auto" settings testings.