A Bricked Lenovo Legion Go

My Lenovo Legion Go bricked a bit ago with no physical damage. I've already turned it in for warranty, I'm just curious if anyone else has experienced something like that. 

  • I had something similar that my device would not turn on. I opened it up, unplugged the battery, hit the power button to drain any remaining power, and plugged it back in. That resolved the problem. It's been working since. I am not sure of the correct term for the issue, but there is some static build-up causing issues. After removing power and draining it from the hardware it clears that up. I see it once in a while with laptops and even some docks at work.

  • I work in the automotive industry, and one of our adages is, "Never buy the first model year of a new car," because it's likely to have issues that have yet to be worked out. It's a bit the same with electronics too...but in my opinion, much harder to adhere to, because I always love getting new tech toys.

    Hope this gets resolved for you soon. Happy gaming!

  • Haven't gotten a LeGO yet, but would definitely fill out a RMA with Lenovo.

  • SO FAR, NO, I HAVEN'T HAD THIS TYPE OF  ISSUE. I GUESS THAT I HAVE BEEN LUCKY TO NOT TO HAVE HAD THAT PROBLEM.

  • Unlucky most likely. Its rare but happens, hoping for the best with your warranty

  • Shoot sorry to hear. Lenovo has good support and sometime tools (Rescue and Smart Assistant) to help recovery. 

  • That's too bad. I haven't had any problems with my Go.

  • Thanks for sharing this tip, if it happens to anyone they can use it to hopefully correct the situation.

  • Did they replace it already?

  • I'm sorry that happened, sometimes motherboards and computer parts work for a while but have problems that cause them to fail. I'm glad you were able to replace it with the warranty!