Legion Go CANT play new game - driver issue

I've been eagerly awaiting the chance to play Hellblade II, having it pre-installed and ready to launch. At 6pm, it unlocked, and I was ready to dive in—exciting! However, after the "recap," I was greeted by a black screen. I tried force quitting and restarting the game, but the issue persisted. Even adjusting the graphics settings didn't help; it just froze and shut down again. Searching Google, I discovered a Reddit thread about Hellblade II, where several players reported the same problem. One solution involved updating the AMD driver by replacing the Lenovo one with a direct download from AMD, which included steps like BIOS adjustments and safe boots. But seriously, for a brand new game on a fairly recent device, it's frustrating that a six-month-old graphics driver could cause such issues. Is this what we can expect now? New games becoming unplayable due to quickly outdated drivers? To say I'm disappointed would be an understatement.

  • No bios adjustments needed. Safe mode is just to uninstall the lenovo drivers for clean state using DDU. Then install amd driver for 7840u cpu. You can look this all up on YouTube and have it all done in 20min

  • You don't need to uninstall the drivers. I'm playing Hellblade to right now and the game is running great. I have the newest AMD 7840u drivers side loaded though. I don't know if you want to do that but the latest drivers are 24.5.1. I saw your post yesterday but didn't want to reply until I had a chance to try Hellblade 2.