Senuas Saga 2

I chatted with support for hours and I still cannot play this game, if I go to settings it freezes, if I try to load a new game it freezes, if I continue it freezes!  I get a black screen sometimes with music most times without them it’ll say timed out.  I updated windows, I updated all the drivers, someone suggested the 24.5.1 when I tried that it wouldn’t let it run and I can’t remember what it said.  I tried  max settings minimum settings went into bios and ran 4 then 8 and maybe I should try auto but I’ve been working on this four about 7 hours and I’m gassed.  Any suggestions for a newbie or a solution?  Thanks ahead of time!

  • Did you look up a video how to install the AMD 780m drivers? They are pesky and need to be installed in a certain way. You should be okay after that

  • Second this. Did you run DDU in safemode then reboot, delete C:\AMD then install 24.5.1?

    Although not ideal, and I'm not exactly happy with the delayed driver updates from Lenovo, but this is something you can take into your own hands, rather than waiting for a release (which, by the looks of things, is going to be outdated when it's released anyway). Also, if you get used to the process (takes about 10-15mins), you will always be able to manually update to the latest driver.

    I've had no issues since moving to manually installing them. In fact, I've seen less issues since using them.

  • I meant to reply a couple days ago but completely forgot. I had the latest amd drivers 24.5.1 since they first released and Senuas saga runs great with little stuttering. The game even plays the same on my MSI Claw surprisingly.

  • I was also frustrated by this. Thankfully I still have a lot of Tsushima to play before getting to Senuas Saga but it is frustrating to have to wait months for Lenovo to release AMD drivers.

  • I had a problem only after downloading the game, if I stream it via Xbox I can play perfectly. Soon as I downloaded and continued game/I was in settings well anything…I would get the black screen as well and would have to force quit it