Legion go cpu boost issue with GPD g1

All of sources gives wrong solution with change USB 4 cable to certified one to prevent GPD g1 eGPU of disconnecting. Wrong! 
The problem is with legion go. Current fix for that is disable cpu boost.

Parents
  • My issue is not disconnecting but the legion go graphics runs most games better. This is using a oneXgpu which is basically the same device 

Reply
  • My issue is not disconnecting but the legion go graphics runs most games better. This is using a oneXgpu which is basically the same device 

Children
  • You can try disable cpu boost. I noticed smoother gameplay in many games.