WiFi - disconnecting from the internet after waking up

Hi,

I've had a Legion Go for a week now. I've noticed a problem with WiFi after waking up the computer. Namely, the Wi-Fi connection is "as if" breaking down. I say "as if" because the connection is there, but the computer shows that there is no internet access (even though there is). What helps is to turn off and on the Wi-Fi. Of course, I have updated everything to the latest versions. Since the actions in the software "solve" the problem, I rule out a hardware problem.

Parents
  • The UI/icon will always perform slower than what is actually happening on your device regardless of what said device is for Windows primarily as it's handling work in the background. If you are actively engaging with the UI in connecting to the internet, it will or should change instantly, but I wouldn't worry about this if the UI says one thing and your device is doing another (showing it's not connected when it actually is). Does this make sense to you or relate to the situation you're having? This is how I'm interpreting it as, just slow UI not matching the speed of the actions taking place.

Reply
  • The UI/icon will always perform slower than what is actually happening on your device regardless of what said device is for Windows primarily as it's handling work in the background. If you are actively engaging with the UI in connecting to the internet, it will or should change instantly, but I wouldn't worry about this if the UI says one thing and your device is doing another (showing it's not connected when it actually is). Does this make sense to you or relate to the situation you're having? This is how I'm interpreting it as, just slow UI not matching the speed of the actions taking place.

Children
No Data