A failed attempt to update to the latest VGA drivers almost had me restore to factory! *Fixed*


I decided to update the AMD drivers to the latest published by Lenovo. Following a restart, AMD software refused to start up with the error msg "This AMD software is not compatible with your AMD drivers".

With no leads to follow, I decided to DDU and start fresh. Drivers successfully installed however, the installer would not install AMD Software.

Spent an hour or so scouring the forums while searching for any useful advice, did one more DDU ... almost gave up until I came across Johnny K's comment (which I modified to match the current VGA driver version) on the Beta VGA thread. Managed to install the AMD Software. Problem solved. 

If you're missing the AMD Settings/Adrenaline App after installing the new drivers do the following:

  1. Download the driver file from the Lenovo Support website.
  2. Run the installer file as Administrator and choose Extract.
  3. Browse to the following location within the folder where you extracted the driver: 31.0.24028.1001\Packages\Appx\RSXUWP
  4. Extract the contents of the radeonsoftware.msix_Windows10_PreinstallKit.zip file. 
  5. Run the 90c30248be704488626a5d3303e7c.msix file (it's the biggest file within the extraction folder).
    1. This file is the correct installer for the Lenovo driver compatible version of the Adrenaline software. 
  6. Once the AMD Radeon Software window loads up press Install. 
    1. The .bat should've taken care of the pre-requisites but, if you get an error after doing this:
      1. Browse to the 31.0.24028.1001\Packages\Drivers\Display\WT6A_INF\UWPPair folder,
      2. Right click on the UWPPair.inf file and click Install.
      3. The installer should work as expected after completing these steps.
  7. After the installer completes, the Adrenaline software should be installed again

Hope this thread helps. Cheers!

  • Thanks for this. I have a tool linked here for the initial error of "This version of Software is not compatible". I have used this before when sideloading. It will only work if AMD Adrenaline is already installed. This time when I went to install the newest driver from Lenovo it didn't give me that error. Not sure if it just overwrote the newest AMD version or what. I initially did the DDU which removed Adrenaline and I couldn't get it reinstalled. Didn't have this guide at the time. Ended up reinstalling 24.5.1 and installing this one over it.

    (direct download link)

  • What would be the post file to download? Did not quite understand. I can't play any more games after the update

  • The official drivers from the Lenovo support website. Sorry that wasn't clear

  • Interesting.... 

    Mine worked fine.

    I did the update over the Legion Space, under settings and driver updates.

    I do find it "funny" that after waiting as long as we did, the orientation of the overlay (Alt-R) is -NOT- landscape once activated during a game. It's kind of insane. I mean, in the end, frame generation seems to be working, just odd the reason for the delay was bugs, and it is still bugged.

    EDIT: is not landscape is portrait, spelling removed the "not"

  • Good to know - thanks for the details

  • I was playing FO3 and NV and the new GPU Driver broke both games. I just rolled it back to the old drivers and it worked. 

    Have to let Lenovo figure all this out. I understand as a customer you want all the things. I also understand as a business things take time and there are pressures amd stressors to put out something to keep the customer base happy. When those two things collide, you have a rushed, snake bit driver and a unhappy customer base. 

    I hope Lenovo takes their time, flushes things out with feedback from the customer base, and put out a great product when it is ready. They are on to something with the Go. 

  • This was mentioned in other posts its the amd side of things that broke it across the board. Not Lenovos version.