Can'tCant play any Games

I just got my Lenovo today.The first thing I did was to update my windows and drivers after that I installed Assassin's Creed Valhalla With Ubisoft and whenever I try to open a game it just loads and keeps on loading and nothing ever happens. So I try to install frozen horizon five With Game pass and still it opens up and then nothing happens so I don't know what is going on with my Lenovo if anyone could help me I would really appreciate Ohh and also I had to update my v ram on the bios from 3 gig to 4GIG and then from 4Gig t to auto but still there's nothing going on so I'm stuck

  • I had the same issue with Valhalla when I first installed it. It was something with Ubisoft. I ended up having to uninstall and reinstall then it started working. I have heard others with some game pass related issues but I don't use it. I would try some Steam games to make sure they work and it's just related to those specific games/launchers.

  • First, try scanning for corrupted windows registries with a sfc scan in command prompt. If registries are all ok, then either go to Lenovo Vantage or Device Manager (click on properties and select update drivers under your graphics card or try any relevant component, maybe cpu, monitor or internet drivers. Lastly, make sure your firewall is not blocking your games. It also could be BIOS is missing an update which can be checked under Lenovo Vantage under update check feature. You can remove Vantage after if you don't want to keep it. Almost forgot to mention, Nvidia Experience app will have updated drivers for games when features are added but usually games will still start up even without the newer driver but may be missing a dlss 3 update or a ray tracing update and so on. If you just bought your Lenovo, you should also have free online Lenovo Support as part of your warranty. It can be accessed through Vantage or Lenovo Support website.

  • Valhalla on game pass or steam? If steam, disable the overlay and try launching it. Most failures to launch on steam can be solved that way.

  • I don't have a Legion Go but I've have a Legion laptop. Using Lenovo Vantage historically solved a lot of my problems. From what I've read Vanatage doesn't work on the Go but there are alternatives for the Go that might like: https://github.com/BartoszCichecki/LenovoLegionToolkit. Having a way to update drivers / firmware is always my go to.

  • solid advice here. Thanks for posting.

  • Bummer.  I would delete the complete program installation and reinstall the game.  Sometimes that works.

  •   

    Can't play any games?!?  Not even Minesweeper or Solitaire? jk

    I think everyone else has covered the "well-informed" advice.  Is it silly to ask... do you own any games which install (and run) without a launcher?  You know?  Good ol' .msi installers and games which launch directly from their .exe?

    You might try installing or running one of those games.  Just to narrow (or widen) the scope of the troubleshooting problem.

  • Wasn't having the Valhalla issue but was with something else and this helped. Thanks a lot.

  • Drivers?  Update everything that you can.  Check Device Manager if there is anything there that's not happy, google it and see if you can resolve it.  Call Lenovo support if you get stuck.  All the best.