Legion go screen not waking from sleep

Hey all. I’ve had my Legion go for 3 days now.Llike many people, I am having issues with the Software.

In particular at the moment whenever my legion go is left innactive and goes to sleep  I cannot get the screen to wake up. Tapping the screen  or touchpad or any button  gets the device to wake up  as i hear the controllers reconnecting  and the screen backlight comes on  but the screen remains black. sometimes quick pressing the power button to turn the backlight back off and then on again wakes the screen but mostly iit does not. Is anyone else having this issue? I've encountered it numerous times when i am trying to copy over steam games from my ssd to my sd card, and I leave it running the transfer. Each time I have had to halt the transfer because the only way i can get the screen back on  (apart from the rare occassions where quick tapping the power button works) is to long hold the power button and force shut down. Appologies if i have missed a fix already mentioned , but i would greatly appreciate some advice on this.  For now i have had to change my power settings to never automatically turn the screen off which obvisously isnt great.

Is this a know problem? or could it be related to a known problem?

Please help!

  • In some computers in the BIOS there is a setting to "Wake from USB Devices." I have a desktop, so I'm not sure if the laptop considers the built in keyboard and trackpad as USB devices, but if that setting is turned off on a computer, inputs from a mouse or keyboard wont wake it back up and you have to press the power button to wake it up.

    From my experience, pressing the power button once is supposed to wake a computer up right away though, you shouldn't need to shut it down, so for it to not wake most of the time after pressing the power button means something else might be going on... Checking to see if the setting in the BOIS does anything couldn't hurt though. I'm not sure what the BOIS key is for your specific laptop, but if you don't know how to get there, you just search on google what the BIOS key is for your laptop, then restart it and as soon as the computer screen lights up keep pressing the BIOS key and it will take you to the BIOS settings.

    Hopefully it's just an issue of some setting being disabled rather than with the laptop or windows or something, but it seems like that could be the issue. Have you tried plugging and unplugging the laptop for a charger when it goes into sleep mode to see if that will wake it up?

  • I've heard of this issue being caused by certain graphics drivers in the past, specifically NVIDIA. This isn't necessarily a fix, but one option would be to adjust the sleep time for your power plan. Control panel --> power options--->change plan settings or right clicking the battery icon in your taskbar and selecting power options from there.

  • Jellis.je, unsure if you've downloaded some of the latest updates for the device, but they might address the issue you're experiencing. When you click on the link below, you should also see other related update version links on the upper right side of the page that opens. Good luck  Thumbsup

    gaming.lenovo.com/.../legion-go-update-11-24-23

  • Offline in reply to Jay

      I'm still experiencing this issue with the latest beta unluckily...

    Currently the only workaround is not to lock the screen, but to just shut down and restart the system each time...

  • Need to try if that could help somehow...

  • Hi Jay. I actually got a workaround from one of the folks over on an unofficial legion go discord group. He suggested the issue was caused by changing refresh to 60hz. I've changed back to 144hz and this seems to have worked for me.

    Also see

     youtu.be/JhQ2Ddiy-Co

  • I'm happy you found a workaround, Jellis.je Thumbsup  I hope a proper fix is released soon Fingers crossed

  • Offline in reply to EvryGama

    EvryGama, check out Jellis.je's reply below for another workaround - selecting 144Hz refresh Eyes

    (I'm just replying here so the Legion site notifies you... in case you haven't visited this thread lately.)

  • It is ironic that 144Hz fixed it, as there was a problem I remember about not being able to switch to 60Hz unless being plugged into A/C power. It seems both problems are related to power, in a way, and frequency (Hz).

  • For me another workaround with the new Bios version 28 was to turn on the fast charging in the BIOS and everything was working at 60 Hz too.