Docked Legion Go is upside down

Greetings. My Legion is docked and linked by hdmi to the 65inch TV. The problem is as seen in the picture, it is casted vertically. I need help to properly cast the image please. Cntrl+alt arrow is useless.

this problem also happens SOMETIMES with the 22inch monitor.

  • Unsure if this is the go-to solution (pun not intended):

    If you visit the Windows Settings, then System, then Display, you should be able to alter the orientation of the monitor to be proper. Provided screenshot is from Windows 10.

    I don't have a Go, but hopefully this helps if you mess with those options available.

  • For me I had to keep messing with the display settings and orientation and it eventually shows correct on my monitor/tv but is always upside down on my go screen. now if i restart my go while already connected to my monitor/tv it displays properly on both.

  • Looks like you're in "duplicate display" mode... would suggest 'second screen only' (windows+p) assuming you don't need both screens.

  • After New BIOS update mine did this undocked , has to change it to landscape flipped Shrug

  • Yes. Or use extend not mirror mode.