Egpu issues

hello i have a sonnet ex 750 egpu enclosure with a 1080ti installed. Device manager sees the card and NVidia control panel is installed. however the control panel wont open even with admin rights. Also, when choosing what app uses what gpu thru windows 11 graphics settings window I only get the amd 780 as a option.

I have uninstalled both NVidia and amd drivers with ddu multiple times. I have tried a couple different versions of the NVidia drivers. I have installed NVidia first and have also installed amd first. Can't seem to figure out what is going on.

Unfortunately I don't have any other tb3 or usb4 devices to test it with.

Any help would be appreciated thanks.

  • I have razer core x, you need to uninstall amd drivers in windows 11 safe mode. Then install nvidia druver whilst still in safe mode. I have a gtx4070 ti super....follow the instructions and you won't go wrong. Once nvidia is installed disconnect nvidia and install amd drivers 

  • I will try this.

    To verify step by step I currently have both amd and NVidia installed.

    1:Use ddu to restart into safe mode and remove amd and NVidia drivers.

    2:Return to safe mode and hook in egpu- then install NVidia drivers.

    3:Unhook egpu and install amd drivers(in safe mode?) or reboot to normal mode before installing amd?

    I have tried similar methods I believe but who knows I have tried so many its blending together Slight smile.

  • got it working thank you