Referral Link Doesn't Work, Any Solutions?

Hi everyone, 

My friend is considering buying a new LOQ laptop, and since he is not a past Lenovo user, he didn't have an account. I gave him my referral link, and he signed up through it. When he clicked the "Join Now" button, a message "No social post with the given code is in our system: [last bit of referral code]" popped up, and prevented him from joining it. He contacted the online support, where no solutions were given. Is there any way to fix this problem?

Thanks!

  • Sorry I'm a little unclear, is this a referral link through gleam widget for giveaway?

  • Ben, I see what this person is talking about. It's part of the Lenovo Rewards program.

    If you go to Lenovo.com/US and click on "My Account", there's a box at the bottom called "My Rewards". Click on "My Rewards", and under Featured Offers, there's a tile labeled "Refer a Friend". Here's how it's described: 

    Refer a Friend
    You and a friend receive $50 in rewards when they make a purchase of $500+. Get your unique link in your Rewards Dashboard. Here's a screenshot for reference.

    And if it helps, here's the link it gave me when I clicked on "Copy Link": account.lenovo.com/.../index.html

  • HOW WAS ONLINE SUPPORT CONTACTED ABOUT THIS PROBLEM?  I WOULD SUGGEST CONTACTING LENOVO AT https://x.com/LenovoSupport

    I WOULD ALSO RECOMMEND YOU TELL YOUR FRIEND TO TRY AGAIN, AND IF THE SAME MESSAGE APPEARS, TO TAKE A PHOTO OF THE MESSAGE AND SEND A PHOTO OF THE ERROR MESSAGE TO LENOVO SUPPORT.  THIS WAY, THE PEOPLE CAN SEE EXACTLY WHAT THE ERROR MESSAGE IS.

  • It is exactly this. Sorry for the late reply, I wasn't able to access this community for a moment. 

  • I contacted the online support and the response they gave was use the link, which was already done countless times before.