Anyone else experiencing these bugs on the newly released Wuthering Waves?

I run Wuthering Waves off Epic Games, and the first bug that occurs is just opening the game. The launcher does not appear, and requires me to open task manager and end the launcher task and reopen to work. Second bug though is a hard Direct X crash, causing random color artifacts throughout the screen and freezing the game. Once this happens, no other game can be opened and other apps glitch out until the computer is restarted. The error notification says something like a Direct X hang or Direct X could not be reached. Sometimes the game runs fine without issue, but when this happens it is pretty bad. Never had anything even close to this bad of an issue on any other games. Anyone here experiencing similar or other bugs?

  • Game just came out, having similiar issues, but a relaunch of the game solved most problems.

    Definitely not as smooth as hoyoverse lol

  • Brand new. Thanks for heads up, will be looking out now for any of these bugs.

  • I'm a bit surprised latest drivers haven't fixed some of these issues. Maybe keep an eye out for any new ones?

  • Yes! fallout 4 at the beginning was super buggy to me, O even worst was Cyberpunk 2077, there is a job I could never finish, because of the bug, were the villain was in a tub or a fridge, I could never get the job to activate and get the villain out.  

  • The Epic Games launcher stinks sooo much. I have the same problem with the Epic Launch opening the Wuthering Waves launcher with it opening in the background. I tried opening the Epic launcher run as admin and the same with the WW launcher. Tried verifying files, and reinstall but no change.

    I just quit and just created a shortcut on my desktop to directly run the Wuthering Waves launcher.

    I had no issues with Direct X crashes. the game runs great on my desktop, and decently as well on my Steam deck on medium settings, low shadows and effects.

    You may want to update your drivers, and close any non essential applications even the ones in your taskbar.

  • I have it but haven't downloaded it yet and am having storage space issues. I never seem to have enough storage. Lol.  Usually when I have game launch problems on Epic, I first try bypassing the Epic launcher by changing the shortcut path as Epic itself is not DRM but rather leaves it up to the publisher. For example, I changed the shortcut path for some of the Sony games I got through last years Christmas sale and now they launch without Epic being open which wasn't possible until I did so. Take in mind that if Wuthering Heights publisher made it so Epic has to verify every time you launch, essentially meaning it is not DRM free from their end, you will not be able to do this. I always go to pc gaming wiki to see what the renamed path is if there is one. When there is a somewhat common issue like launch problems a fix is usually posted. Another thing I do is to check if another app is interfering with it or if my firewall setting for the game is blocking it. Otherwise it is most likely driver issue on your device in which the waiting game kicks in. Hopefully it gets an official fix. I have a few titles in my backlog before I play it. I am addicted to Balatro at the moment since I picked it up recently.

  • Hope no issues for long

  • I recently started playing Wuthering Waves on my phone. I luckily don't have any issues that you mentioned. It could be something to do with Epic Games rather than the actual game.