Weird bug on EDU that locks me out of all access to Lenovo websites

I went to reply to the "Python Courses" thread in the Study Zone group on EDU, but when I click on the thread to open it, I get hit with an ""Access denied, you don't have permission to access 'this' on this server” error and then get the same error when I try to access anything on any of the Lenovo websites after getting the error from the thread; EDU, gaming, the main store, rewards, my account, etc. Basically any domain or subdomain on Lenovo.com. I also tried on different browsers and got the same error.

The only way to recover is to delete all my cookies and restart my browser and log in again.

It only seems to happen when I try to open the "Python Courses" thread. Coincidentally, that thread seems to have been created around the same time as the last big update around 11 days ago.

Here's the direct link to the thread, but click at your own risk since it might give you the same error. If you do get locked out, just clear you cookies and restart your browser to recover.

https://education.lenovo.com/us/connect/groups/study-zone/f/forum/696/python-courses

  • Hey Richie! Hmm weird, normally that error appears as a result of trying to access a Lenovo page too many times consecutively (bot protection). But you're seeing it consistently on that page only?

    Has it been happening for a few days? Normally just waiting 10ish minutes should clear this error message.

  • It first happened a day or so ago when I clicked the thread to reply since I've taken many online Python courses and the thread never opened. It went right to the error and then I wasn't able to access any Lenovo websites until after I cleared my cookies. I tried to open it with both Chrome and Edge and got the same error. I tried again last night and got the same thing. It only seems to happen with that one thread. Although, I haven't really checked a whole lot of them, but it's the only one I've gotten the error on and it seems to happen only when I click that thread. I can try from a different computer as well to see if I also get the error and let you know. Should I copy the reference number it also gives me? Would that help?

  • I just tried to open the Python Courses thread on a tablet I don't think I've ever even used before to access EDU.

    I went to EDU, didn't even sign in, and tried to open the thread. As soon as I clicked the thread, I got:

    Access Denied
    You don't have permission to access "http://education.lenovo.com/us/connect/groups/study-zone/f/forum/696/python-courses" on this server.
    Reference #18.9a2d2d17.1677011762.c0f175

    It's really weird. Am I the only one having issues with that thread?